This document highlights any known issues with regards to compatibility when using DriveWorks products.
Problem Code: 7.51201
Cause:
This is a known issue when manually activating a DriveWorks 23 license.
Solution:
Closing the Activation Failed dialog, and re-opening the application or License Manager will have actually successfully activated the license.
In some circumstances installation of DriveWorks could fail.
This is due to some DriveWorks Services (DriveWorks License Server) being left over when previous versions have been uninstalled.
To resolve:
Perform in order from newest to oldest.
Check services each time to ensure expected services appear and then disappear.
The Team Viewer feature - Mirror Driver is known to cause issues with 3rd party applications, including DriveWorks.
If you receive a message stating that a new project cannot be created, and you have Trend Micro Anti-virus installed, please try disabling Trend Micro Anti-virus and creating your project. This issue is caused by Trend Micro Anti-virus locking the new project file before DriveWorks has a chance to open it.
DriveWorks is aware of an issue, where in some instances only, selecting certain sections of the Capture Assistant in the SOLIDWORKS Add-in will crash the Add-in and SOLIDWORKS.
This is related to the Microsoft .NET September 2022 Update and occurs irrespective of the fix that was built in to DriveWorks 20 SP2.
If this occurs apply the fix detailed here: Workaround 1: Suppress the new behavior caused by the update (Preferred).
DriveWorks is aware of an issue, where opening certain stages in DriveWorks Solo will crash immediately with UpdateExtent shown in the title of the crash dialog.
See Info: Microsoft.NET Update Crash for more information and workarounds.